Monday, September 12, 2011

Swap partition in AIX

By default, swap space is defined as 512 Mb which is a little bit low when oracle, websphere or any other enterprise application would be running. Hence, it will be important to increase the swap space before the installation of these applications.

 lsps -a
Page Space      Physical Volume   Volume Group Size %Used Active  Auto  Type Chksum
hd6             hdisk0            rootvg       512MB     1   yes   yes    lv     0
AIX put swap space on hd6 by default.

To increase the swap space, use 'chps -s xxx hd6' command where xxx mean by how many PP you want to increase.
lsps -a
Page Space      Physical Volume   Volume Group Size %Used Active  Auto  Type Chksum
hd6             hdisk0            rootvg       12480MB     1   yes   yes    lv     0
swap -l
device              maj,min        total       free
/dev/hd6              10,  2     12480MB     12448MB
tmp in AIX

We know that /tmp is using tmpfs which is essentially swap in solaris. However, in AIX, /tmp is using the usual file system 'jfs2'. This means that whatever is placed in /tmp/ would not be wiped out after reboot as the space really have a allocated disk space.

AIX put /tmp on hd3 by default.
df -k | grep tmp
/dev/hd3          6291456   2706240   57%     4993     1% /tmp
See that the files from 2010 are still around.
ls -lt /tmp/ | tail -5
d-w-------    2 root     system          256 Nov 12 12:12 errmbatch
-rw-r--r--    1 root     system          530 Nov 12 11:33 IBM.CSMAgentRM_dr.sh.dbg
-rw-------    1 root     system            0 Nov 12 11:30 .strload.mutex
-rw-r--r--    1 root     system          406 Nov 12 11:26 .sr_migrate.log
drwx------    2 root     system          256 Nov 12 10:41 lost+found
Uptime is only 15 days, which prove that the above files from 2010 are really not wiped out.
uptime
  02:59PM   up 15 days,   3:03,  3 users,  load average: 1.50, 1.77, 1.87
Timestamp for the sake of completeness.
date
Thu Apr  7 14:59:55 GMT+08:00 2011
Good or bad? i don't think this is critical to the performance nor operation of the system hence i recommend to leave it alone.

No comments: